Hi, after trying to get Realdash to work on a Sm4 V1.09 I think I need to upgrade to at least V1.09-6. With the possibility of going to E85 in the future...