Announcement

Collapse
No announcement yet.

Over temp IAT on SM4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Over temp IAT on SM4

    So I have a bit of a different issue with intake temps to most people.

    I have the SM4 using the factory Autronic intake temp sensor on a supercharged non-intercooled alcohol engine combo.

    As you can see by the data log attached below, near the end of the run the intake temps are reaching 150 deg C.

    The temp itself is not what I am concerned about, the fact that once it reaches this temp, it appears to go into a limp mode.

    Intake temps default to 25 deg C and the ecu increases the injector time which then obviously effects the engine afr.

    I am guessing this is due to reaching the max default for the sensor or it's settings. But I am unable to find these anywhere?

    What are my options in this situation?

  • #2
    M1 I/P Anallogs I/P Intake Temp Limp home limit. Should be set to 168 C for an Autronic sensor.
    He gets his lap dogs to do his talking for him. Buzzard is a good example.

    Comment


    • #3
      That is one of the places I expected it to be. But as you can see by the attached screenshot, it doesn't give you any options?

      Would this be due to only running v1.07 still?

      The other screenshot shows the only limp home tables that have been setup in the ecu also.

      Comment


      • #4
        Yes, that option becomes available in 1.09, so may I suggest you have that ecu updated.
        He gets his lap dogs to do his talking for him. Buzzard is a good example.

        Comment


        • #5
          Bugger. Is there anything that could be done in the meantime?

          As I won't have a chance to get it upgraded before the next race meeting.

          Comment


          • #6
            Perhaps. If you go online with the ecu, temporarily change the I/P intake temp to Linearization 1 (if not used ) and set all values in the Linearization 1 table to 2000. If the ecu shows the intake temp as 200 C, it may be possible to program the sensor values s into Linearization 1 table. If the ecu shows 25 C, then we need the update.
            He gets his lap dogs to do his talking for him. Buzzard is a good example.

            Comment


            • #7
              Well looks like I do have to upgrade to the later chip.

              Any settings over 150 deg just defaults back to 25 deg.

              It was worth a try, thanks for the help Chris.

              Comment


              • #8
                I thought there might be a get out of jail free option there, but no such luck. Whre are you located ?
                He gets his lap dogs to do his talking for him. Buzzard is a good example.

                Comment


                • #9
                  Yeah, it was certainly worth the try.

                  I'm located just outside of Brisbane.

                  I have actually already purchased a v 1.12 chip. But after a repair a couple of years ago, the chip was soldered onto the board.

                  So I will have to return it back to Richard to have the chip changed out. Just haven't had a chance as yet.

                  Comment

                  Working...
                  X