Announcement

Collapse
No announcement yet.

Is the Innovate LM2 analog output ground (negative) isolated?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is the Innovate LM2 analog output ground (negative) isolated?

    Hi,
    Does the Innovate LM2 analog output suffer the same non-isolated ground issues as other Innovate products like the LC1, or is it just a matter of getting the span and offset right in the SM4? I found reference in the LM2 documentation to the analog outputs being differential (also called floating I believe) and was wondering if that language indicated ground isolation. As a side note, I've found Span = 3690 and Offset = 735 on this forum as those to try for the LM2 in case anyone can confirm them.
    Thanks.

    Text from LM2 manual.
    "The analog outputs on the LM-2 are differential. As with the analog inputs, the negative lead (-) must be connected to ground for the readings to be accurate."
    Last edited by nitz; December 20th, 2017, 01:21 PM.

  • #2
    Apologies for the slow response. The diferential output of the LM2 should not cause any issues. I checked the manual and Page 20 option 2 is how you should hook it up. I have a single ended to diferrential converter that I use with my NGK AFX. It has a similar diffential output and works fine.
    Last edited by Chris; January 12th, 2018, 01:08 AM.
    He gets his lap dogs to do his talking for him. Buzzard is a good example.

    Comment


    • #3
      No problem and thanks for replying. That is how it is wired up with the lm2 negative to pin 22 and the positive to pin 38 for o2 input on the SM4. I couldn't get it to read the same in the SM4 but have been away and haven't tried the Span = 3690 and Offset = 735 values as yet. If those don't work I'll have to make sure pin 22, sensor ground, isn't being taken to chassis ground for some odd reason.

      Comment


      • #4
        The offset value is correct, however I calculate the span as 3324.46, so you could use 3324 or 3325. As an alternative you could program the LM2 output to 0-5V= 10-20 AFR and use a span of 5000, and an offset of 1000. This is the approach I would take, as it improves the resolution of the analog output . This should work well provided there are not any issues with the unit resetting and reverting to the original settings.
        Last edited by Chris; January 12th, 2018, 01:14 AM. Reason: typo
        He gets his lap dogs to do his talking for him. Buzzard is a good example.

        Comment

        Working...
        X