Announcement

Collapse
No announcement yet.

Tuning a stable idle control

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I keep fine tuning my idle whenever I have free time, but I can't beat an odd behavior right after start - my RPM would oscillate up and down for some time, before it settles, no matter how small my IAC adapt rates are....

    the only observation I made, is that it begins settling down once the wideband is warmed up and operational, but I don't have CL enabled, so I see no connection
    Attached Files

    Comment


    • #32
      In my experience, immediate post start oscillations are due to either the fuel table being incorrect at about 400 - 600 rpm, or the IAC 0 rpm position being incorrect or the IAC enrichment factor being incorrect.

      Comment


      • #33
        I think I figured it out
        I noticed my car is running pig rich under cold start - I gave up on the charge table, doesn't matter what values I try I can never get it to work in the broad temperature range. In fact, I ended up having to use fuel trims to richen the fuel map once IAT hit 50* and above

        so what I did was zero out (mult = 1.0) my enrichment multipliers and idles from the coolant temp range of 20* and above, and only left warn up fast idle values untouched - that did the trick! I will do more testing, and I might need to increase the post start multiplier for hot start region, because usually car runs a bit lean on hot starts (I understand the process behind it and why it occurs, but don't understand why the charge table/fuel trims don't react right away)
        Last edited by Hyper; April 12th, 2018, 09:51 PM.

        Comment

        Working...
        X