Announcement

Collapse
No announcement yet.

Help Please: BMW E46 M3 (s54b32) Cal file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help Please: BMW E46 M3 (s54b32) Cal file

    I have be struggling for a while trying to get an answer to a trigger pattern for a S54B32 engine. I have done searches on here with not much luck. I found one person saying to use a S50B32 cal file to try and start it. This is also what Richard sent us to try at first. Yes it starts the engine but it misses on cylinder 1 for some unknown reason. Then I found MRM posted on a thread that you could use M01 and set it up as a 2 stroke with 3 event cycles. We tried that and it started and ran perfect. But once we started to run it up it had a random miss now and again. So I'm not really convinced that this setup is right for it either.

    If someone has done a E46 M3 (S54B32) could you please help me out with a cal file with the correct setup for the crank/cam trigger.

    Thanks in advance

    Allan

  • #2
    Are the sensors both magnetic or is one Hall type.
    Can you run a scope trace with SM4 (if1.09) and post it,
    Robert Jansson
    MRM-Racing

    Comment


    • #3
      Crank is 60-2 - inductive
      Cam is 7 teeth on intake and 6 on exhaust - hall

      As I was not using vanos I just cut away 6 teeth on the intake cam trigger wheel and used that as my cam trigger. It worked flawlessly.

      When using vanos I do not know what to do.

      Comment


      • #4
        Originally posted by MRMRacing View Post
        Are the sensors both magnetic or is one Hall type.
        Can you run a scope trace with SM4 (if1.09) and post it,
        Crank is 60-2 magnetic and cam is 6 teeth and hall.

        I will post up one asap.

        Comment


        • #5
          Originally posted by kristov View Post
          Crank is 60-2 - inductive
          Cam is 7 teeth on intake and 6 on exhaust - hall

          As I was not using vanos I just cut away 6 teeth on the intake cam trigger wheel and used that as my cam trigger. It worked flawlessly.

          When using vanos I do not know what to do.
          Ah ok. That makes a big difference. I still have vanos. Was considering deleting it. Wanted to get it all going without removing the vanos first just so I didn't have the extra costs of the delete kit.

          Comment


          • #6
            Talk to Ian or Richard to se if you can get a file done for this.

            But since it misses when you set it up like a 2 stroke and only use crank sensor I feel like it can be an error in your crank sensor or wiring? (polarity or interference)
            Robert Jansson
            MRM-Racing

            Comment


            • #7
              The polarity of the crank sensor can be quickly confirmed with a PC scope trace.

              Is the car in Canberra? I thought the cams had 8 teeth.

              Comment


              • #8
                Originally posted by MRMRacing View Post
                Talk to Ian or Richard to se if you can get a file done for this.

                But since it misses when you set it up like a 2 stroke and only use crank sensor I feel like it can be an error in your crank sensor or wiring? (polarity or interference)
                Yeah we sent Richard the scope of this and he sent back a s50 file last week thinking it was the same thing. But it doesn't fire on cylinder 1 at all.

                Comment


                • #9
                  Originally posted by Ian View Post
                  The polarity of the crank sensor can be quickly confirmed with a PC scope trace.

                  Is the car in Canberra? I thought the cams had 8 teeth.
                  Yes the car is in Canberra. You probably don't remember me talking to you about this 12 months ago. It's the turboed one. You and Richard said to me at the time that you couldn't do this setup so I was using an AEM since then. Had some warranty issues with it and it started getting expensive sending the ECU back to the US to get repaired. Freight is a killer. I was having a conversation with Ed about another car with an Autronic and the BMW came up in the discussion and he said that he thought that we could the BMW with Autronic now. That's why I decided to change to the Autronic.

                  And sorry you are correct with the cam teeth I was thinking about two things at once when I was typing that. The intake cam has 6 teeth and the exhaust cam have 8. I'm using the exhaust cam sensor as the reference because it is a fixed signal. The intake cam sensor varies with the vanos.

                  The PC scope of this to Richard but he sent back an S50 cal file which misses on cylinder 1. We tried a couple of other things over the weekend with no luck. Thought I would get on here and ask to see if we could get an answer since doing a search Kristov had done an S54. But his setup is a bit different. Looks like we might just have to wait for Richard and/or yourself to decode this trigger pattern and send it back to us since it looks like to this day still no one has done a S54 with an Autronic with factory trigger pattern.
                  Last edited by LETSPLA; April 12th, 2010, 02:08 PM.

                  Comment


                  • #10
                    Did this ever get resolved?

                    Thanks,
                    Tony

                    Comment

                    Working...
                    X
                    okeygabilesohbetdikmen evden eve nakliyatdireksiyon dersifreier pornoFilm porno francaisko cucehttps://www.ko-cuce.net/index.php?forumlar/server-tanitimi.5/ko cucebtc yorumpornohd videoshindi porn videospornhdvideoČeské Porno zdarmajigolokayitci #yaslikurt# Hack haber instagram hackleme sitesi Hack forum